How to delete bad PWS data

By: Kari Strenfel , 9:54 PM GMT on August 04, 2014

Hi PWS Owners!

Has your station reported bad data and now your summary table is out of whack? Bad data can result from many things:

1) When setting up your station's data communication, and you and your station are indoors with your compute nearby, it will report the indoor temperature for outdoor temperature.

2) When mounting your station on the roof, a fencepost, or on a pole in the backyard, you may tip the rain bucket sensor (registering 0.01 inches of rain every time it clicks or tips!),

3) Cleaning out the rain bucket with water. It needs to be done but it is reporting erroneous rainfall data.

4) Moving your station to direct sunlight with a poor radiation shield can report significantly warmer temperatures than nearby stations.

5) Mounting your station near an attic vent will also report warmer temperatures.

In all of these cases (and many more) you should go into your station's PWS Dashboard or history page and delete this bad data. Otherwise, it will be reflected in your summary table and skew your data. You can access your PWS data here:
My Weather Stations



You can edit your station data if you are logged into wunderground.com. Go to your PWS dashboard page (or history page) and select the date you are interested in.  Switch to the "Tables" view and there will be a blue edit button above the table of data.  The great feature of our new PWS Dashboard is you can delete multiple data points at once by holding down the control key while clicking. Try it and let me know how you like it!

While many of you know about this feature and use it, we want to make sure everyone feels comfortable editing their data. Also, we have launched a new edit feature to the PWS Dashboard. You can now edit your UV and Solar Radiation data. Please let me know if you have any questions or problems deleting bad PWS data. And as always, let me know if you have any questions or concerns regarding your PWS or your PWS Dashboard.

Thanks,
Kari


The views of the author are his/her own and do not necessarily represent the position of The Weather Company or its parent, IBM.

Reader Comments

Comments will take a few seconds to appear.

Post Your Comments

Please sign in to post comments.

Log In or Join

Not only will you be able to leave comments on this blog, but you'll also have the ability to upload and share your photos in our Wunder Photos section.

Display: 0, 50, 100, 200 Sort: Newest First - Order Posted

Viewing: 97 - 47

Page: 1 | 2Blog Index

97. EXTREAME
11:17 PM GMT on February 13, 2017
I also noticed we are all members since January 1st, 1970, look at our posts, they state we are all members that joined back in 1970, was the internet even alive back then?
Member Since: December 31, 1969 Posts: Comments:
96. EXTREAME
11:15 PM GMT on February 13, 2017
Quoting 93. EYNW:

Still does not work, as of January 2017. Interface allows you to delete data points, but after you refresh the page, they're back again.


Yep same with me, I have a whole 361.7mm in one month, and I live in South Australia, we don't even get that amount in one year.

EDITOR OF DATA DOES NOT WORK = I STILL HAVE BAD DATA AND UNABLE TO ADD THE CORRECT AMOUNT.
Member Since: December 31, 1969 Posts: Comments:
93. EYNW
3:19 PM GMT on January 27, 2017
Still does not work, as of January 2017. Interface allows you to delete data points, but after you refresh the page, they're back again.
Member Since: December 31, 1969 Posts: Comments:
92. CypressMike
10:24 PM GMT on January 21, 2017
I've tried multiple times to delete some bad data, but it keeps reappearing. Is something wrong with the feature?
Member Since: December 31, 1969 Posts: Comments:
91. NE40weather
7:19 AM GMT on January 01, 2017
I can't get this function to work... My old equipment died so I got some new gear but the process of decommissioning and then setting up the new stuff indoors has given me some data that needs deleting.

Despite multiple attempts on multiple browsers on multiple computers the bad data comes back!

Plus even when it looks like it's gone from the table view the graph view still shows it and even worse the daily/weekly/monthly/annual high/low/average are still including the bad info...

Bad data is:
26/12/2016 1652 to 1722
28/12/2016 2105 to 2221

Station ID is ICRAWCRO3.

Kari - please can you help ?
Member Since: December 31, 1969 Posts: Comments:
90. Apple8
12:09 AM GMT on November 22, 2016
Hi Kari, I had some bad data for minimum temperature and dew point upload on July 14 2016. Although I was able to delete the daily data at the time the summaries still show the bad data for station INSWLEUM2 in the yearly summary etc.

Is there a way to correct the bad data,

Regards, Apple8
Member Since: December 31, 1969 Posts: Comments:
89. mgoblue62
8:10 PM GMT on November 16, 2016
Can you add the capability to edit the values instead of just deleting them? My station was offline from WU last night and I missed a half inch of rain being reported. I can go out and drip that much through the station today but being able to change a value instead of just deleting it would be great.
Member Since: December 31, 1969 Posts: Comments:
88. CypressMike
8:17 PM GMT on November 08, 2016
How do you get the daily and monthly totals corrected after deleting bad data? I was cleaning my Vantage Pro2 ISS over the weekend and must have gotten some water in the ISS housing that created a short, resulting in 0.61" of erroneous rainfall. Unfortunately I didn't notice the bad data until after we received 2.9" of "real" rainfall later that day. I deleted the erroneous data, but that didn't correct the daily/monthly total. And in looking at the chart, the line stays at 0.61" until the real rain started.
Member Since: December 31, 1969 Posts: Comments:
87. TidalWaveOne
9:05 PM GMT on September 15, 2016
I don't see any "Tables" view there? Is this article too old?
Member Since: December 31, 1969 Posts: Comments:
86. Fletc05
3:04 PM GMT on June 21, 2016
Any configutation? Between the weather staion and the computer and into the program weather sta data logger is showing okay but the info in PWS and WU internet site shows wrong temperature 60 dg when it should be 86.2 dgs... ANy help?
Member Since: December 31, 1969 Posts: Comments:
85. AndyAyre
12:22 PM GMT on May 23, 2016
This feature is rubbish. I cannot delete my bad data. Either clicking on "Delete" does nothing or it says it is deleting but doesn't. The data is still shown and when I click on return to data view it says "are you sure? You have unsaved changes". Very annoying.

Can you please delete the stupid high temp data for Oct 23 - 26th 2015 for me? Thank you! IHORNSEA3
Member Since: December 31, 1969 Posts: Comments:
84. jmds
11:54 PM GMT on May 21, 2016
I tried to delete some erroneous data sent from weatherlink to wunderground site but was still unable.

My ID is ICAIRNS1

Best regards:John
Member Since: December 31, 1969 Posts: Comments:
83. treponema
11:32 PM GMT on May 19, 2016
I've tried to delete several erroneous data points on 18 & 19 May (wind, temperature). I highlight the data, delete, answer "yes" and the data remains. I have tried this with IE 11 and Chrome on two different computers on different networks.

I also have erroneous graph and summary data for high temperatures on several past dates, yet the data does not appear in the tables. How do I clear this?

The erroneous high temperature data is below:
Date - False high - True high
Apr 30 - 129.9 - 64.8
Apr 7 - 126.8 - 69.1
Apr 1 - 107.7 - 57.2
Mar 22 - 108.1 - 59
Mar 13 - 130.3 - 61.7
Mar 10 - 88.2 - 66
Feb 21 - 132.3 - 55.9
Feb 7- 88.1 - 43
Feb 3 - 102.5 - 30.7
Feb 2 - 103.5 - 32.4
Jan 31 - 102.7 - 37.2
Jan 30 - 103.7 - 43
Jan 27 - 85.9 - 36.3
Jan 9 - 100.8 - 37.2
Dec 29 - 85.3 - 26.1
Member Since: December 31, 1969 Posts: Comments:
82. WildRossendale
4:28 PM GMT on May 17, 2016
Quoting 81. Uica:



Same here - I cannot delete bad data. Exactly the same behavior as described above. Tried with Safari and Firefox on Mac, and with IE11 on Windows.


I am also finding this. Everything goes as should but it never deletes the data.
Member Since: December 31, 1969 Posts: Comments:
81. Uica
3:20 PM GMT on May 14, 2016
Quoting 79. Ballaughweather:

I had some error values for rainfall today 8 May during the afternoon but when I tried to delete the incorrect values I can select ok and when I click delete a popup box gives a yes or no option click yes and it says deleting but when I scroll down to the value they are still highlighted and the error values are still showing and the delete box still says the number of items selected using Win 10 and IE 11 this suggest the delete is failing.



Same here - I cannot delete bad data. Exactly the same behavior as described above. Tried with Safari and Firefox on Mac, and with IE11 on Windows.
Member Since: December 31, 1969 Posts: Comments:
80. smokeybandit
3:18 PM GMT on May 14, 2016
Is this still supposed to be supported?

I get "unsupported request" errors when I try to delete any of my data
Member Since: December 31, 1969 Posts: Comments:
79. Ballaughweather
10:18 PM GMT on May 08, 2016
I had some error values for rainfall today 8 May during the afternoon but when I tried to delete the incorrect values I can select ok and when I click delete a popup box gives a yes or no option click yes and it says deleting but when I scroll down to the value they are still highlighted and the error values are still showing and the delete box still says the number of items selected using Win 10 and IE 11 this suggest the delete is failing.
why is there no modify option so the correct value can be put in to replace the incorrect value
Member Since: December 31, 1969 Posts: Comments:
78. MSprad
2:39 AM GMT on April 26, 2016
I have some rainfall accumulation that seems to be the result of the weather station being jostled while I was trying to shore up the mounting pole. I have deleted it numerous times but it seems to keep coming back.
Member Since: December 31, 1969 Posts: Comments:
77. Meteoservice
8:51 AM GMT on February 29, 2016
When I remove my wrong data, i refresh the page and data come back. It can't be deleted permanently. I'm on mac / Chrome, up to date.
Member Since: December 31, 1969 Posts: Comments:
76. deegeepee
4:58 PM GMT on February 21, 2016
Quoting 72. jfoneil:

Hi,
I need to delete some bad data from my PWS Weather History table, but I only see a DOWNLOAD button. There is no EDIT button. Please tell me what I need to do to delete the data.
Thank you.


Hi - if you go to a single day view, you will see the delete button
Member Since: December 31, 1969 Posts: Comments:
75. deegeepee
4:57 PM GMT on February 21, 2016
Hi Kari
I am trying to use the "delete data" functionality to tidy up some old erroneous data, and frequently the data is deleted ok, but when I go back in it appears to have been reinstated again. Happens very very frequently when deleting say a block of data when a sensor has been misreading or not reporting. I had a rain sensor too high on a pole, and was getting incorrect errors for the rain flow, seems the bucket was tipping when the pole "wobbled" in high windows.

I am getting fed up of deleting data and then finding it re-appears some time later. And no, it isn't my station resending data, because I flused out the old data exactly for that reason and started again in the new year.

Very frustrating and also find that after pressing "edit" in firefox, I frequently get a "page not responsive" error in the script. Same seems to happen when I click "go back to data" in google chrome. I guess those two scripts are the ones crashing and losing the changes I am making.

Many thanks

David Pursehouse
Member Since: December 31, 1969 Posts: Comments:
74. deegeepee
4:56 PM GMT on February 21, 2016
Hi Kari
I am trying to use the "delete data" functionality to tidy up some old erroneous data, and frequently the data is deleted ok, but when I go back in it appears to have been reinstated again. Happens very very frequently when deleting say a block of data when a sensor has been misreading or not reporting. I had a rain sensor too high on a pole, and was getting incorrect errors for the rain flow, seems the bucket was tipping when the pole "wobbled" in high windows.

I am getting fed up of deleting data and then finding it re-appears some time later. And no, it isn't my station resending data, because I flused out the old data exactly for that reason and started again in the new year.

Very frustrating and also find that after pressing "edit" in firefox, I frequently get a "page not responsive" error in the script. Same seems to happen when I click "go back to data" in google chrome. I guess those two scripts are the ones crashing and losing the changes I am making.

Many thanks

David Pursehouse
Member Since: December 31, 1969 Posts: Comments:
73. pasw
12:42 PM GMT on February 21, 2016
Hi Kari

I just deleted precipitation data from 5 of February but in monthly statistic and in Summary for 5 of February still appear 113 mm of rain

What I have to do to delete these wrong data because I want to have an accurate statistic for whole period

I saw this kind of error also for wind speed in the past.

Thank You

Dan
Member Since: December 31, 1969 Posts: Comments:
72. jfoneil
5:20 AM GMT on February 17, 2016
Hi,
I need to delete some bad data from my PWS Weather History table, but I only see a DOWNLOAD button. There is no EDIT button. Please tell me what I need to do to delete the data.
Thank you.
Member Since: December 31, 1969 Posts: Comments:
71. WeatherWatchUK
4:32 PM GMT on February 01, 2016
Hello

All of the summary sheets say that a high of 16 degrees Celsius was recorded at around 10am or so on 29th January, which is when the station was briefly brought indoors. Yet when I go to the daily data record it isn't there.

Also, I have some erroneous rainfall readings from the rain gauge being knocked about, but when I delete these the summary data doesn't change these the individual records then re-appear.

Matt.
Member Since: December 31, 1969 Posts: Comments:
70. CanMan72
11:44 PM GMT on January 08, 2016
My PWS was reporting too high rainfall amounts - I deleted the data points but the accumulated number still shows on the page and is very high. Is there a way to reset that number?
Member Since: December 31, 1969 Posts: Comments:
69. NutsNuts
9:54 PM GMT on January 06, 2016
Same as others, I deleted a row of bad data from Jan 2015 but it is still showing in the monthly totals, very frustrating!

Member Since: December 31, 1969 Posts: Comments:
68. MoonFri
6:25 PM GMT on November 22, 2015
I deleted all the rain data for November 21, 2015 but the summary still shows .45". Is there a time delay to update the summary? I was changing the fan motor and should have disconnected from the network first.

Thanks

Member Since: December 31, 1969 Posts: Comments:
67. beeedge
5:55 PM GMT on October 14, 2015
Found this post because I'm trying to delete some data points from when my station (ISCOTLAN258) was being set-up inside. I can select the data row, but when I try to confirm (Yes, Delete) nothing at all happens. I can only "Go back". Any ideas? I would like to remove data points before 5.33pm

UPDATE: This was a browser issue, Chrome didn't work, Safari works.
Member Since: December 31, 1969 Posts: Comments:
66. HurricaneSmith
9:36 AM GMT on September 05, 2015
I would suggest that as of this time and date there a problems still existing somewhere. I have been seeing bad data for nearly a week now. I have been recently informed by a wunderground operative that although they admitted they are receiving errors erratic/noisey data from me they implied I had a battery and or hardware problem my end. This I refute!! My data is being received with no problem with the data received on my personal website and other sites I publish to.

as an example how can I have and and accumulated rainfall of 1.8mm from 1205 this morning when it didn't start raining until 0410?

Its all well and good getting the sender to edit his own "BAD DATA" that isn't even being sent but I have a time consuming hobby and I accumulate over a quarter of a million bits of data every month from around the world!! I don't have time to sit at my PC editing this data.

I therefore apologise to all PWS users who may be reading my info at IBUCKING13 for any errors being noted thereone

Member Since: December 31, 1969 Posts: Comments:
65. iceage05
2:40 AM GMT on June 02, 2015
Like alot of others I can delete speific data but the totals do not change, on 31st May my PWS spat out a rainfall of 10690.9mm at 6:20pm! Ihave deleted all raibn data for the day but the daily total still shows 10690.9, which is of course now my record high, please advise thanks
Member Since: December 31, 1969 Posts: Comments:
64. dolfs
6:06 AM GMT on April 24, 2015
I found this entry because I am having the problem with some entries reading -999 etc. All such entries are on 4/15/2015 and 4/16/2015 for my station KCAMOUNT75.

Interestingly enough, in the table view these are displayed as "--" which is reasonable as I deleted the data that was originally there (and it was not -999). If I attempt to delete these rows again, they display completely blank, but the rows stay in existence and I think that is the problem. I delete the whole row, but instead, the record remains with null/-999 values. Also, the daily hi/low summaries for these days show very strange values as a result because the -999 values are used to compute min/max and average, which is obviously incorrect.

I need these values to be deleted completely, but there appears to be no way to do it. The values cause problems in the (daily) summaries, but also show up in API history requests, and graphs in the iPad application are messed up. For example, the pressure graph automatically determines the vertical scale. Due to the presence of the -100 inHg values, the vertical scale is from 0 to 31 which means that, effectively, I cannot see daily changes.

I see in older messages that you have been able to delete such data. Please do so for the data indicated above. Thank you.
Member Since: December 31, 1969 Posts: Comments:
63. neuwirw
10:57 AM GMT on April 06, 2015
Deleting data doesn't work at all
Member Since: December 31, 1969 Posts: Comments:
62. cartmanG
4:18 AM GMT on March 24, 2015
I fixed an issue where my weather station was sometime sending out bad data, namely a high temp, high wind speed, and excessive rain. I've just restarted posting data to WU, and there is some bad data that I'm not seeing when I go to the edit section of the table view. There were some that I saw that I removed, but the summary section is still showing the invalid data. I know I'm sending in data more often than the table is showing, is there a way to view everything I've sent in and delete the outliers?
Member Since: December 31, 1969 Posts: Comments:
61. photog123210
2:08 PM GMT on February 14, 2015
Thanks for the idea on deleting bad data. Now how do I change the summary values to reflect that? -Scott
Member Since: December 31, 1969 Posts: Comments:
60. AllenJL
8:41 PM GMT on February 12, 2015
I have a Ambient Weather WS-2090 connected to MeteoBridge 2.5 (5816) running on TP-LINK TL-MR3020. Ever so often it shows an outside temperature 60.0°C 140.0°F. I can delete from the Wunderground table. But it still shows in the summary High temperature. See http://www.wunderground.com/personal-weather-stati on/dashboard?ID=KGATOCCO3#history/s20150211/e20150 211/mdaily
Member Since: December 31, 1969 Posts: Comments:
59. Kari Strenfel , Meteorologist
11:48 PM GMT on February 03, 2015
Quoting 52. Citibroker:

Dear Kari

I am trying to remove faulty Dew Point data from the PWS table -> IZUGRISC2 (period 18.6.2013 - 30.06.2013) but once I delete the column the Information remains (-573C). My Station does not appear on WunderMap anymore - is the faulty Dew Point the reason for this?

Thanks

Marcus


There is an issue we are aware of with average dew point not getting deleted when you are in degrees C. Our developers are working on it and it should be fixed soon.
Thanks,
Kari
Member Since: December 31, 1969 Posts: Comments:
58. Kari Strenfel , Meteorologist
11:42 PM GMT on February 03, 2015
Quoting 51. TomWeatherman:

I want to add/change rainfall data in the summary table - my tipping bucket gauge was out for a few days and missed recording rainfall, but I have backup data from a plastic gauge and want to add that in to the summary. Can't figure out how to do this.


You cannot edit data. We only allow for you to delete data.

Thanks,
Kari
Member Since: December 31, 1969 Posts: Comments:
57. Kari Strenfel , Meteorologist
11:41 PM GMT on February 03, 2015
Quoting 50. g11dge:



Thanks for the update Kari, unfortunately I can still see the erroneous data. The approach outlined above is the same approach I took to try and delete the erroneous data. The deleted data appears to come back upon a refresh of the page, do you experience this too?


I do not see the bad data on the graph. Do you still see the bad data on Nov 4th and 12th? It looks fine in Chrome and Safari, what browser are you using?
Thanks,
Kari
Member Since: December 31, 1969 Posts: Comments:
56. patiasao
8:54 AM GMT on January 15, 2015
I began reporting with only the internal sensor for more than one day, an then, when I installed the station, I began to report all data. Due to that, my temp graphs in iPad Wunder Station app had been showing the left axis beginning in -17 ºC and showing an too plain graph line.

To fix it, I erased the data of these two days, but it worsened the problem, because now I have also the pressure graph left axis also beginning in 0, and a plain line at the graph (In monthly and yearly view). Seems that the app takes the erase data as zeroes and not as "no data".

How can I really erase that data or change two days the initial day of operation of my station? I know that I can delete my station and begin again, but I should like to avoid lost my (short) historical data.

Thanks a lot. My PWS is registered with you as ICUNDINA18.

Alvaro Morales
La Calera, Cundinamarca, Colombia (Nearby Bogota)

PS. Excuse my bad english: I speak Spanish only.
Member Since: December 31, 1969 Posts: Comments:
55. SustainableGuy
7:20 PM GMT on December 26, 2014
I just moved my weather station and referred to this post to remind myself how to delete data, but I kept missing that I needed to click on the GRAPHS tab vs the TABLE tab and floundered around for a while looking for the TABLE formatted data. Could you consider updating your blog post to remind people to do this? Guy (KMEWOOLW2)
Member Since: December 31, 1969 Posts: Comments:
54. nickjhall
10:44 PM GMT on December 15, 2014
Hi,
I've used this to delete erroneous data from setting up my PWS.
Seems to work fine on the website, but the graphs on WunderStation on my iPad interpret all the cleared data fields as zeros.
Is it possible to clear all the data so it doesn't appear on WunderStation?

PWS: IHIGHLIT3
All data before 7:24pm on 15th dec is erroneous

Nick
Member Since: December 31, 1969 Posts: Comments:
53. aqu32
10:21 AM GMT on December 11, 2014
Hi Kari,
I deleted some bad wind data (avr. speed gust) which suddenly appeared this morning, but unfortunately day min/max remain untouched. Would be possible to edit it for me, because that bad data appears to be station's all-time records right now.
Station's ID: IWOJEWDZ30
Date: December 11, 2014

Best regards,
Arek

edit:
After 3 days, the problem fix itself
Member Since: December 31, 1969 Posts: Comments:
52. Citibroker
10:32 AM GMT on December 08, 2014
Dear Kari

I am trying to remove faulty Dew Point data from the PWS table -> IZUGRISC2 (period 18.6.2013 - 30.06.2013) but once I delete the column the Information remains (-573C). My Station does not appear on WunderMap anymore - is the faulty Dew Point the reason for this?

Thanks

Marcus
Member Since: December 31, 1969 Posts: Comments:
51. TomWeatherman
4:49 AM GMT on December 08, 2014
I want to add/change rainfall data in the summary table - my tipping bucket gauge was out for a few days and missed recording rainfall, but I have backup data from a plastic gauge and want to add that in to the summary. Can't figure out how to do this.
Member Since: December 31, 1969 Posts: Comments:
50. g11dge
12:08 PM GMT on November 25, 2014
Quoting 49. PWSmet:



Okay, I have deleted all of these erroneous "0" points for you on both dates Nov 4th and Nov 12th. I simply used the control + click method to select multiple points at a time.
Thanks and let me know if you find any more data you cannot delete yourself.
Kari


Thanks for the update Kari, unfortunately I can still see the erroneous data. The approach outlined above is the same approach I took to try and delete the erroneous data. The deleted data appears to come back upon a refresh of the page, do you experience this too?
Member Since: December 31, 1969 Posts: Comments:
49. Kari Strenfel , Meteorologist
8:35 PM GMT on November 21, 2014
Quoting 47. g11dge:



ICHESTFI2

November 4, 2014 everything before 5:10PM - this data was sent with rapidfire enabled. The '-- C' appears to be interrupted as '0 C' on the graphs.

November 12, 2014 - 4:55 PM - Communication was lost and upon startup, a blank entry was sent, which again is interrupted as '0 C' on the graphs.

If the cell is deleted, it is updated to '--' (without the degree c) and the graphs appears as expected.


Okay, I have deleted all of these erroneous "0" points for you on both dates Nov 4th and Nov 12th. I simply used the control + click method to select multiple points at a time.
Thanks and let me know if you find any more data you cannot delete yourself.
Kari
Member Since: December 31, 1969 Posts: Comments:
48. okestone
11:05 PM GMT on November 15, 2014
I like the delete bad data feature a lot.
Member Since: December 31, 1969 Posts: Comments:
47. g11dge
5:11 PM GMT on November 12, 2014
Quoting 46. PWSmet:



What dates do you see the bad data? I don't see any bad data when I load your history.
Kari


ICHESTFI2

November 4, 2014 everything before 5:10PM - this data was sent with rapidfire enabled. The '-- C' appears to be interrupted as '0 C' on the graphs.

November 12, 2014 - 4:55 PM - Communication was lost and upon startup, a blank entry was sent, which again is interrupted as '0 C' on the graphs.

If the cell is deleted, it is updated to '--' (without the degree c) and the graphs appears as expected.
Member Since: December 31, 1969 Posts: Comments:

Viewing: 97 - 47

Page: 1 | 2Blog Index

Top of Page
Ad Blocker Enabled

PWSmet WunderBlog

About PWSmet

A gathering place for PWS owners to learn about setup, installation and maintenance. Regular features of owners doing cool things with their PWS data!

Recommended Links