Known Bugs on the new PWS Dashboard

By: Kari Strenfel , 8:22 PM GMT on April 29, 2014

Share this Blog
0
+

Hi all,

Thanks for all of your comments. This has really helped us figured out more bugs with the PWS dashboard. We are still working on the issue with deleting bad data. The edit is saved for that day, but is not saved when you view the data for that week or month - or custom time period that includes that day.

Also, there has been a precipitation accumulation and precipitation rate issue. We are actively working on solutions to these issues. As always, please leave your feedback and comments here as it helps us pinpoint the issues to focus on next.

Thanks for your support!
Kari

Reader Comments

Comments will take a few seconds to appear.

Post Your Comments

Please sign in to post comments.

or Join

Not only will you be able to leave comments on this blog, but you'll also have the ability to upload and share your photos in our Wunder Photos section.

Display: 0, 50, 100, 200 Sort: Newest First - Order Posted

Viewing: 57 - 7

Page: 1 | 2Blog Index

57. WunderAlertBot (Admin)
7:32 PM GMT on May 09, 2014
PWSmet has created a new entry.
56. Kari Strenfel , Meteorologist
7:11 PM GMT on May 09, 2014
Quoting 52. metmknuk:

1. The text on the "y" axis of the graphs is truncated - i.e. only the last few characters appear - the column appears to be too
narrow.

2. Choosing "yesterday" to view the graph doesn't appear to show the correct graph - as there is no date on the graph itself I don't know what is being displayed.
However if you choose the date for yesterday instead of clicking the "yesterday" button, then click done, the correct graph is displayed.


The developers are aware of these problems and are currently working a solution.

Thanks,
Kari
Member Since: January 30, 2014 Posts: 11 Comments: 41
55. Kari Strenfel , Meteorologist
7:07 PM GMT on May 09, 2014
Quoting 50. lrymal:

Things are really looking better. Do we have an added feature request page? ;>)

I would like to see a running total tally for rainfall through the year in the history area. I am surprised, I guess, that my Rainwise station's software doesn't include that. I think I could do that myself with the raw data from just the rainfall column in a spreadsheet, but....

Thanks, y'all..........


You can view the running tally of precipitation for the year to date by selecting the custom date. Set the start date to the first of the year and select today as the end date.

Thanks,
Kari
Member Since: January 30, 2014 Posts: 11 Comments: 41
54. Kari Strenfel , Meteorologist
7:05 PM GMT on May 09, 2014
Quoting 49. garykirk:

Kari,
Once again, I URGE you to please post a list of problems/bugs/"bad features" which you are working to correct and their current status. This would help all of us who would like to help YOU improve/fix this new site. To paraphrase an old quote, "Those who don't know a problem/bug/"bad feature" has been reported are doomed to repeatedly report them!".

By the way, when do you anticipate having the solar data back in the tables??
Gary



Hi Gary, solar will be returned to the tables in the next couple of weeks. We are diligently working on addressing all of these issues, so I'm trying to update the users once things have been fixed.

Thanks,
Kari
Member Since: January 30, 2014 Posts: 11 Comments: 41
53. WeatherGoose
6:27 PM GMT on May 09, 2014
Quoting 45. PWSmet:



We are aware of this problem and are working on a solution. Thanks for your patience and support while we continue working on these fixes.


Thanks for the reply!

Glad to hear it!

Something even more urgent...

Any ETA on when the WIND SPEED indicator is going to be fixed? As I reported a few weeks ago and was confirmed by several other PWS operators... The WIND SPEED number is not updating and instead is frozen on what ever value it picks up when you first load the page. That number remains displayed in the center of the circle until the user forces a refresh of the entire page. Then a new value is displayed but once again will remain the only value the user will see until they refresh the entire page again.

Your real time wind speed display was one of my favorite features and since we are using a 2 second Rapid Fire stream, our station's wind speed is as close to real time as you can get using the Rapid Fire upload option.
Member Since: January 14, 2009 Posts: 178 Comments: 30
52. metmknuk
11:31 AM GMT on May 09, 2014
1. The text on the "y" axis of the graphs is truncated - i.e. only the last few characters appear - the column appears to be too
narrow.

2. Choosing "yesterday" to view the graph doesn't appear to show the correct graph - as there is no date on the graph itself I don't know what is being displayed.
However if you choose the date for yesterday instead of clicking the "yesterday" button, then click done, the correct graph is displayed.
Member Since: July 17, 2011 Posts: 0 Comments: 0
51. newnesi
7:19 AM GMT on May 09, 2014
I like the look of the new dashboard but I note there is a problem with the units displayed on the y axes of the Graphs tab. It looks like the problem is related to the available space. Attached is a screenshot that shows the problem.
Regards,
Craig

https://dl.dropboxusercontent.com/u/43617275/Voil a_Capture%202014-04-14_12-32-34_.png
Member Since: October 14, 2011 Posts: 0 Comments: 0
50. lrymal
9:30 PM GMT on May 08, 2014
Things are really looking better. Do we have an added feature request page? ;>)

I would like to see a running total tally for rainfall through the year in the history area. I am surprised, I guess, that my Rainwise station's software doesn't include that. I think I could do that myself with the raw data from just the rainfall column in a spreadsheet, but....

Thanks, y'all..........
Member Since: July 11, 2005 Posts: 0 Comments: 9
49. garykirk
11:21 AM GMT on May 08, 2014
Kari,
Once again, I URGE you to please post a list of problems/bugs/"bad features" which you are working to correct and their current status. This would help all of us who would like to help YOU improve/fix this new site. To paraphrase an old quote, "Those who don't know a problem/bug/"bad feature" has been reported are doomed to repeatedly report them!".

By the way, when do you anticipate having the solar data back in the tables??
Gary
Member Since: January 6, 2011 Posts: 0 Comments: 10
48. leoploeg
10:14 AM GMT on May 08, 2014
I love the new page format, keep up the good work.
Member Since: November 27, 2011 Posts: 0 Comments: 0
47. I90IL25
2:59 AM GMT on May 08, 2014
Quoting 44. speedycactus:

Two station PWS owner here...

I've gone back to classic because it's infinitely easier to use, more intuitive. New site is slow and cumbersome with too many button presses and tabs required in addition to being very slow to load.

Interesting that some prefer the new graphs, as on my 23 inch screens the graphs are too large to easily take in the set period's display. IOW, I prefer the smaller graphs from before.

1) scale on the left of graphs is truncated on all my devices...can't tell whether windspeed is 10, 20 or 30 mph!
2) bring back "previous" and "next" tabs on history page. Drop the tedious menu.
3) Incorporate the tables and graphs on the same page - fix the scaling so that less scrolling is necessary.
4) Wind gust color on graph is so light (compared to the blue wind speed) so as to be hard to distinguish. I'm much more interested in gusts than steady state winds. Perhaps reverse the colors?


Thanks for listening!


I couldn't agree more (except #4, I don't think the gust color is too light, but that's not the main issue). I honestly believe the site is still in beta mode. Today my station reported a few bad temps before I caught it and it was painful trying to delete them using the new website. I selected the cells I wanted to delete and clicked on the delete button, but since I had scrolled all the way to the bottom, there was no way to know that another dialog box opened up all the way at the top of the page (out of view). I switched to the classic mode and fixed everything in under 10 seconds as it should be. After using it for a while, here are the things I really dislike and need to be fixed:

1) The graph sometimes extends the entire width of the chart even if it only has a few hours of data.

The tables need a lot of work
2) Why must the column names repeat every 15 spots? Why not just have a column bar that stays put while the data scrolls?
3) Bring back the row for heat index and wind chill. Why was it taken out in the first place? It used to just appear automatically. If i want to know these values for a previous day, I would need to enter my temp and wind speed (or dew point) into an external site to get it. This is what I want to see get fixed the most.

4) speed. It's so slow.
Member Since: June 8, 2013 Posts: 0 Comments: 0
46. CaminoCielo
10:55 PM GMT on May 07, 2014
One piece of PWS data is just invented. My station does not report UV, but a number is provided as though it does.

I do not perceive that the Dashboard is an improvement at all. What is improved?
Member Since: September 13, 2013 Posts: 0 Comments: 3
45. Kari Strenfel , Meteorologist
9:59 PM GMT on May 07, 2014
Quoting 42. WeatherGoose:

The PWS Weather Widget is Broken!

I just tried out the new PWS Weather Widget and as others have already reported, it appears to be broken. I see a missing image icon on the actual creation page which carries over to the actual web page when the code is copied and pasted into the html file.

Here is the test page I created to check out how this new version looks which currently displays a (?) where the actual widget is supposed to be displayed.

Link


We are aware of this problem and are working on a solution. Thanks for your patience and support while we continue working on these fixes.
Member Since: January 30, 2014 Posts: 11 Comments: 41
44. speedycactus
5:30 PM GMT on May 07, 2014
Two station PWS owner here...

I've gone back to classic because it's infinitely easier to use, more intuitive. New site is slow and cumbersome with too many button presses and tabs required in addition to being very slow to load.

Interesting that some prefer the new graphs, as on my 23 inch screens the graphs are too large to easily take in the set period's display. IOW, I prefer the smaller graphs from before.

1) scale on the left of graphs is truncated on all my devices...can't tell whether windspeed is 10, 20 or 30 mph!
2) bring back "previous" and "next" tabs on history page. Drop the tedious menu.
3) Incorporate the tables and graphs on the same page - fix the scaling so that less scrolling is necessary.
4) Wind gust color on graph is so light (compared to the blue wind speed) so as to be hard to distinguish. I'm much more interested in gusts than steady state winds. Perhaps reverse the colors?


Thanks for listening!
Member Since: February 20, 2007 Posts: 0 Comments: 1
43. JohnW
12:59 PM GMT on May 07, 2014
I don't know if the problem I'm experiencing is because of a setting or monitor setup but on charts and graphs the left labels are cutoff by the left-side vertical station info. This is particularly problematic with the the barometric charts where the left-hand digit is cut off
Member Since: January 1, 2006 Posts: 0 Comments: 1
42. WeatherGoose
6:38 AM GMT on May 07, 2014
The PWS Weather Widget is Broken!

I just tried out the new PWS Weather Widget and as others have already reported, it appears to be broken. I see a missing image icon on the actual creation page which carries over to the actual web page when the code is copied and pasted into the html file.

Here is the test page I created to check out how this new version looks which currently displays a (?) where the actual widget is supposed to be displayed.

Link
Member Since: January 14, 2009 Posts: 178 Comments: 30
41. willowsbasket
2:10 AM GMT on May 07, 2014
The new graph I really like. Seeing the expected barometric pressure lines, and % of cloud cover etc. really gives me a better idea of what to expect.
Member Since: September 7, 2009 Posts: 0 Comments: 0
40. Tmax
11:02 PM GMT on May 06, 2014
Very hard time finding thing coming from the older to the newer. Different locations mostly. You need to make whats available on every menu available as a link on the page because i found your menu structure not as easy to navigate under the new dashboard and its SLOW!!!!!!!!!!!!!!!!
Member Since: February 18, 2003 Posts: 6 Comments: 15
39. acradiodoc
6:56 PM GMT on May 06, 2014
For the most the new dashboard is great, but I have noticed that it is slow loading on my Android 4 phone and on both my phone and Windows tablet the scale along the left side of the wind speed and temp is truncated. For example when I look at the 10 and 20 all I see is 0. I can figure it out so it is just a minor thing.

Jim
Member Since: October 2, 2007 Posts: 0 Comments: 0
38. katy99780
2:17 AM GMT on May 06, 2014
I would like to see the option to click on 'previous day' on my PWS history, rather than the drop down menu provided now. (yesterday, past week, past month, past year, or pick a date from another drop down menu within that drop down menu...) It is cumbersome and awkward, having to scroll down the page and click 'done' when you want that day's data to load, and 'done' is way down off the page, making it necessary to scroll for that.

I use RH data, wind velocity/ direction data, and bar. pressure data to make daily WX reports to Natl WX service, and when I need to retrieve data after a multi-day absence, the service provided now is not nearly as accessible and user friendly as having 'previous day' 'previous day' 'previous day' available for individual day's data, as it was in the past.

Also, my particular location in Tok Alaska is far from a radar site, so absolutely no radar data is available now for my area. On previous site, at least NEAREST radar was available, with large map that I could animate and get a general movement of weather systems and rotations, possibly approaching/retreating my area.

Now I have to go to the nearest location that is covered by radar, if I want to do that evaluation.
Member Since: October 3, 2005 Posts: 0 Comments: 12096
37. RemmingtonWX
2:50 PM GMT on May 05, 2014
Widget code not displaying picture.Same problem as uclm:There seems to be a problem with the PWS widgets. The widget on my website only shows a question mark. Same as when I'm trying to create a new
Member Since: November 11, 2009 Posts: 0 Comments: 0
36. uclm
12:55 PM GMT on May 05, 2014
There seems to be a problem with the PWS widgets. The widget on my website only shows a question mark. Same as when I'm trying to create a new

Member Since: August 7, 2011 Posts: 0 Comments: 0
35. richardwvan
11:06 AM GMT on May 05, 2014
I love the new dashboard! The new mobile version of the site is great too. Good luck getting the bugs worked out. This was a pretty big change in function and design but overall it looks like it went well.
Member Since: December 12, 2007 Posts: 1 Comments: 0
34. Superwoofercp
8:38 PM GMT on May 04, 2014
I can't believe that my station has had 1433 hits in 4 days. Could it be my webcams fault?
33. WeatherGoose
7:51 PM GMT on May 04, 2014
Surprised that the WIND SPEED indicator on the new Dashboard is still broken. I reported this problem last week and several other PWS owners confirmed the same problem.

Speed does not update with changes sent from station. Compass Rose updates, but speed is static and only updates with a new value if you manually refresh the page.

This seems like a pretty major problem compared to most of the other far more minor complaints. ????
Member Since: January 14, 2009 Posts: 178 Comments: 30
32. tbull
6:37 PM GMT on May 04, 2014
Quoting 30. tbull:

WonderMap - I sure miss the "map types " option . I used it frequently for various observations and would be grateful if it were added . Thanks


Wow ! You already have it . I located map types on the wondermap.....after a search search double search... Why does this "new" site have to be so complicated ? sigh.....oh well .
Member Since: December 24, 2005 Posts: 0 Comments: 2
31. rbsailor
6:10 PM GMT on May 04, 2014
In the Graphs tab of Graphs & History for the PWS, the left Y-axis labels are getting chopped off. I'm using Chrome.

Temp is ok with two digits.
Wind speed only shows part of a single digit in mph.
Wind direction is ok.
Rain and Baro pressure instead of "XX.YY in" only shows ".YY in".
Solar radiation and UV index are both ok, but nowhere does it show the units.

Suggest placing the units for each graph on the respective legend color bar, which will free up space on the left Y-axis to read the values without units.
Member Since: July 7, 2008 Posts: 0 Comments: 0
30. tbull
4:11 PM GMT on May 04, 2014
WonderMap - I sure miss the "map types " option . I used it frequently for various observations and would be grateful if it were added . Thanks
Member Since: December 24, 2005 Posts: 0 Comments: 2
29. RenoSoHill
5:26 PM GMT on May 03, 2014
On the PWS map of my area - the zoom is no longer available. No stations are listed in south Reno and without the zoom feature - MY station and others in my area are no longer available for the "choose station." This is a feature that seems to come and go depending on what revision WU is currently on your site. The elevation can vary around my area by 500 ft per miles so having to use a station 10 miles away is not accurate. Then taking in the wind prone area and winds vary by 25 mph in a couple of miles -The choice of stations available just isn't working at this point. (and it is disappointing not to be able to view my PWS) KNvRENO51

Update: Found the zoom boxes - used a magnifying glass to determine what that was in the little box - Most stations in the Reno area do not appear on the map !!
Member Since: December 12, 2009 Posts: 7 Comments: 10624
28. rickstrachan
1:25 PM GMT on May 03, 2014
I would like to make requests about the Current Conditions Window. 1. I wish the graph would resize automatically so that new high or low data points do not get chopped off. 2. I wish the graph would show the entire 24hr period all the time like on the old window, and not show only the progress of the day as the day progresses. I would like to attach a screen shot of this to this comment but I don't know how to.
Member Since: September 4, 2011 Posts: 0 Comments: 0
27. storm1968
9:50 AM GMT on May 03, 2014
I have found one problem, I want to show wind speed in MPH and KPH on my display but when I set it to both I still only get KPH is this a fault in the way I am doing my setting or is this an issue across the board.
Geoff
Member Since: June 23, 2013 Posts: 0 Comments: 1
26. DJinNM
5:27 AM GMT on May 03, 2014
I sent you an email earlier, Kari, but thought I would follow up here. As I mentioned, I'm just getting dashes in the precip column (when actually .97 " was recorded on 4/2, albeit erroneously). I want to adjust the erroneous reading (caused by moving the station), but can't figure out if the dashes are a bug or "operator error". BTW, this is station KNMMOUNT3.
Member Since: September 20, 2001 Posts: 0 Comments: 1
25. janeslogin
9:09 PM GMT on May 02, 2014

Quoting 23. 4250:

""With the change to the new format I can no longer use the 'Change Station' feature ... "  I can go to a nearby station but cannot make the click on it work.

Member Since: November 14, 2013 Posts: 0 Comments: 5
24. garystofer
8:06 PM GMT on May 02, 2014
Quoting 22. KevinKey:

Also, can we get history/graphs of Soil Temp and Soil Moisture?

Thanks,

Kevin


I can't even find any table entries for soil moisture etc-- Can someone from WU (Kari) please comment on this. Has this been dropped or is it not yet implemented or am I looking in the wrong place.

Thanks

GaryStofer -- WunderWeatherStation
Member Since: May 18, 2009 Posts: 7 Comments: 3
23. 4250
3:28 PM GMT on May 02, 2014
With the change to the new format I can no longer use the 'Change Station' feature - just goes dark and nothing happens. The station for 48108 is a poor choice and I now can't change it.

Is that going to be fixed? On a Mac, running OS 10.6.8 with Safari Version 5.1.10 (6534.59.10).

Just want to know one way or the other so I can make a decision on how to deal with that.

Thanks,

RICK
Member Since: May 2, 2014 Posts: 0 Comments: 0
22. KevinKey
6:28 AM GMT on May 02, 2014
Also, can we get history/graphs of Soil Temp and Soil Moisture?

Thanks,

Kevin
Member Since: October 16, 2013 Posts: 0 Comments: 2
21. KevinKey
6:26 AM GMT on May 02, 2014
Some bugs I've noticed:

Wind speed doesn't refresh properly.
Soil Temp doesn't refresh.
Soil Moisture doesn't refresh.

Thanks,

Kevin
Member Since: October 16, 2013 Posts: 0 Comments: 2
20. garystofer
5:40 AM GMT on May 02, 2014
Have you looked at the dashboard with the OPERA browser (Opera 12.17). It renders absolutely horrible. Font is barely visible at any zoom level and the wind rose circle looks more like a rectangle when not at 100% zoom. Login and Preference Icon is not drawn and pull down menus don't work.
Member Since: May 18, 2009 Posts: 7 Comments: 3
19. archae86
4:20 AM GMT on May 02, 2014
Here is an oddity on the table view--for this sequence, one gets to a table page which is labelled as spanning three days, but in fact spans a month.

Setup sequence: (behaved this way  a little after 10:00 p.m. MDT May 1, 2014 in both Firefox 29 and Chrome 34.0.1847.131 m)

  • Go to the main page for my PWS 
http://www.wunderground.com/personal-weathe r-station/dashboard?ID=KNMALBUQ102
  • click on graphs and history
  • change the time range control from "today" to "last month"
  • change the time range control to "custom" with start March 13, 2014 and end March 15, 2014
  • click on the "tables" tab
Now here is the trouble for both of these browsers, this sequence gives you a tables page for which the titles assert that the time period is March 13 through March 15.  However the actual table has a first row labelled as time 0:05 on March 13, extending with about eight rows per day up through time 21:24 on April 13!  The time interval between rows is sometimes 2 hours 50 minutes, sometimes 3 hours, and perhaps other values.
I suspect something here is not as intended.

Member Since: November 12, 2009 Posts: 0 Comments: 8
18. archae86
4:05 AM GMT on May 02, 2014
Let me echo W2IRT in praising the appearance of text time readout on more of the graphs than originally.  That is a really nice improvement.
In a less happy echo, I have once or twice observed, as I think mchaser described here, the graph page content not to appear at all.  I can't provide a replication sequence, so I don't suppose this is much help.  At the time I saw it I was in Chrome, but with only one observation that can't be regarded as a significant correlation.  The site I was looking at was my own: KNMALBUQ102
Member Since: November 12, 2009 Posts: 0 Comments: 8
17. RLClark
3:09 AM GMT on May 02, 2014
Get rid of those big black lines on wundermap it causes the to chop off part pf map.
Member Since: April 2, 2013 Posts: 0 Comments: 0
16. W2IRT
2:45 AM GMT on May 02, 2014
Thanks for including the time on mouseovers. This was huge, and greatly appreciated.
Member Since: August 2, 2012 Posts: 0 Comments: 2
15. PeriColeman
2:42 AM GMT on May 02, 2014
Tried to update my old weather station widget on my web page, to reflect your new logo etc, but where the graphic elements and current conditions should be there is just a blank space. The "Click for forecast" takes you through nicely to the weather station page OK. Thought I would use a sticker instead, but it would not let me select my PWS as the location (ISASTKIL2)
Member Since: July 25, 2010 Posts: 1 Comments: 0
14. WestwoodPark
9:24 PM GMT on May 01, 2014
The precipitation rate and accumulation are working well for me, and I love the new graph with both. However, I miss the precipitation accumulation in the table. I would often check the values against my CoCoRahs gauge and subtract off what had fallen by 7am. Now I have to mouse over the graph to find the right datapoint, which is more cumbersome. Any chance you could bring that back to the data tables? Thank you.
Member Since: February 18, 2011 Posts: 0 Comments: 1
13. catdon
5:41 PM GMT on May 01, 2014
Would be nice if we had the ability to change data if needed and not just delete it.
Member Since: August 8, 2008 Posts: 0 Comments: 1
12. mchaser
12:51 PM GMT on May 01, 2014
My graphs have vanished. Is there something I can do to bring them back?
Member Since: March 28, 2012 Posts: 0 Comments: 0
11. PVFA
2:03 AM GMT on May 01, 2014
So, I assume at when you are done fixing the price accumulation problem, that it will accumulate for the full duration of the period requested, rather than reset every 24 hours?
Member Since: May 3, 2013 Posts: 0 Comments: 0
10. janeslogin
12:06 AM GMT on May 01, 2014
When the closest PWS is down I click on nearby PWS and find others but I cannot click on these others to determine if they are down,  The little hand shaped cursor turns into a pointed finger cursor indicating clickable but clicks do nothing.
Member Since: November 14, 2013 Posts: 0 Comments: 5
9. pjh21
6:15 PM GMT on April 30, 2014
Another request: I think it would be better to display the actual time of the last update instead of the elapsed time since the last update.
8. JadeWx
4:38 PM GMT on April 30, 2014
Is there some reason you can't fix the rapid-fire wind speed problem? It was reported a week ago. One has to use the classic site to see the updates properly.
Member Since: October 15, 2012 Posts: 0 Comments: 10
7. DeFoWeather
4:22 PM GMT on April 30, 2014
Table info when looking at history/past week has issues - precip total is showing total for day and not total for past week. Also once I go to looking at week data - I would much rather see daily summary info in the table vs. current view of weather as reported on a given interval (5 minutes?)
Member Since: August 11, 2012 Posts: 0 Comments: 0

Viewing: 57 - 7

Page: 1 | 2Blog Index

Top of Page

About PWSmet

Kari is the PWSmet. As a meteorologist at wunderground.com, she has experience setting up and installing many types of personal weather stations.