How to delete bad PWS data

By: Kari Strenfel , 9:54 PM GMT on August 04, 2014

Share this Blog
2
+

Hi PWS Owners!

Has your station reported bad data and now your summary table is out of whack? Bad data can result from many things:

1) When setting up your station's data communication, and you and your station are indoors with your compute nearby, it will report the indoor temperature for outdoor temperature.

2) When mounting your station on the roof, a fencepost, or on a pole in the backyard, you may tip the rain bucket sensor (registering 0.01 inches of rain every time it clicks or tips!),

3) Cleaning out the rain bucket with water. It needs to be done but it is reporting erroneous rainfall data.

4) Moving your station to direct sunlight with a poor radiation shield can report significantly warmer temperatures than nearby stations.

5) Mounting your station near an attic vent will also report warmer temperatures.

In all of these cases (and many more) you should go into your station's PWS Dashboard or history page and delete this bad data. Otherwise, it will be reflected in your summary table and skew your data. You can access your PWS data here:
My Weather Stations



You can edit your station data if you are logged into wunderground.com. Go to your PWS dashboard page (or history page) and select the date you are interested in.  Switch to the "Tables" view and there will be a blue edit button above the table of data.  The great feature of our new PWS Dashboard is you can delete multiple data points at once by holding down the control key while clicking. Try it and let me know how you like it!

While many of you know about this feature and use it, we want to make sure everyone feels comfortable editing their data. Also, we have launched a new edit feature to the PWS Dashboard. You can now edit your UV and Solar Radiation data. Please let me know if you have any questions or problems deleting bad PWS data. And as always, let me know if you have any questions or concerns regarding your PWS or your PWS Dashboard.

Thanks,
Kari

Reader Comments

Comments will take a few seconds to appear.

Post Your Comments

Please sign in to post comments.

or Join

Not only will you be able to leave comments on this blog, but you'll also have the ability to upload and share your photos in our Wunder Photos section.

Display: 0, 50, 100, 200 Sort: Newest First - Order Posted

Viewing: 41 - 1

Page: 1 — Blog Index

41. Kari Strenfel , Meteorologist
10:24 PM GMT on October 20, 2014
Quoting 33. hymrog:

I had an unexpected problem and my station reported empty data for several days. I am now unable to delete the "null" data. Please see July 31, 2014 as an example. I have tried to delete single and multiple points but they just reappear.

Any suggestions on how to correct or when will we be able to correct. Also I recieve script error messages on your page when trying to delete

Thanks


It looks like you were able to go in and delete all data points for July 31st. Please let me know if you need any additional help with this.

Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
40. Kari Strenfel , Meteorologist
10:23 PM GMT on October 20, 2014
Quoting 34. aviation76:

I lost internet connection during a storm and my weather station was not able to relay rain totals to WU. Is it possible to add rainfall total to my data?

Thank you.


No, you can only delete data, not add new data or edit existing data. Some weather station software back-fills data after the power has gone out. If your software didn't do this automatically, it is probably not an option.

Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
39. Kari Strenfel , Meteorologist
10:22 PM GMT on October 20, 2014
Quoting 36. webrian:

Unfortunately this feature still does not work ... I managed to delete single values, but not to delete a whole row. Then I tried to overwrite these data using the PWS Upload Protocol, but this didn't work either. It seems to me that with the upload protocol it's only possible to add new data, but not update any older datasets.


This is true - you cannot use the Upload Protocol to edit data. It is only for adding new data. What date are you seeing the bad data? I would be happy to go in and delete for you.
Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
38. jdelapen
2:35 PM GMT on October 16, 2014
Thanks Kari. It looks fixed now.

Quoting 37. jdelapen:

Kari,

Please help me to delete a single bad data point from station INLMONTE8. I have tried it all with no success, including the procedure indicated on this blog. Something is really wrong with the delete function on your website. Even though the data is in some way deleted, it does not update all the tables around the global database. The bad data point is a 60°C temperature registered yesterday, October 13 at around 6:25 PM. I would really appreciate if you can delete it directly from the database in order to keep data integrity.

Thanks in advance for your support on this matter.

Member Since: January 28, 2013 Posts: 0 Comments: 2
37. jdelapen
3:30 PM GMT on October 14, 2014
Kari,

Please help me to delete a single bad data point from station INLMONTE8. I have tried it all with no success, including the procedure indicated on this blog. Something is really wrong with the delete function on your website. Even though the data is in some way deleted, it does not update all the tables around the global database. The bad data point is a 60°C temperature registered yesterday, October 13 at around 6:25 PM. I would really appreciate if you can delete it directly from the database in order to keep data integrity.

Thanks in advance for your support on this matter.
Member Since: January 28, 2013 Posts: 0 Comments: 2
36. webrian
2:13 AM GMT on October 14, 2014
Unfortunately this feature still does not work ... I managed to delete single values, but not to delete a whole row. Then I tried to overwrite these data using the PWS Upload Protocol, but this didn't work either. It seems to me that with the upload protocol it's only possible to add new data, but not update any older datasets.
Member Since: August 7, 2014 Posts: 0 Comments: 0
35. DK7FM
8:30 PM GMT on October 09, 2014
Nice tool, but it doesn%u2019t work for a lot of us%u2026
i am not able to delete datas from the table. when i select them, delete them, they are still there, but i cannot select and delete them again, the delete-button is without a function then.
it is because of some errors from my setup here, and some data dont fit into the chart and table....
Member Since: October 2, 2014 Posts: 0 Comments: 0
34. aviation76
2:46 AM GMT on October 03, 2014
I lost internet connection during a storm and my weather station was not able to relay rain totals to WU. Is it possible to add rainfall total to my data?

Thank you.
Member Since: September 8, 2013 Posts: 0 Comments: 0
33. hymrog
11:04 AM GMT on October 01, 2014
I had an unexpected problem and my station reported empty data for several days. I am now unable to delete the "null" data. Please see July 31, 2014 as an example. I have tried to delete single and multiple points but they just reappear.

Any suggestions on how to correct or when will we be able to correct. Also I recieve script error messages on your page when trying to delete

Thanks
Member Since: November 21, 2012 Posts: 0 Comments: 0
32. Kari Strenfel , Meteorologist
8:48 PM GMT on September 29, 2014
Quoting 31. Chris2fourlaw:

I have moved my weather station and I need all my data removed but the edit button is grayed out so I can't do this.


How far did you move your station? If you move your station more than 2 blocks, we ask that you re-register your station on Weather Underground to obtain a new Weather Underground station id. This is for historical data purposes so it is clear that the data is associated with this new location.

If you only moved it around your property, you should be able to edit if you are logged into your account on Weather Underground. Click the edit button, then click on the points you would like to delete, then go back to the top of the table and hit the button to delete these points.

Thanks and let me know if you have any other questions or need help deleting points.
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
31. Chris2fourlaw
9:37 PM GMT on September 27, 2014
I have moved my weather station and I need all my data removed but the edit button is grayed out so I can't do this.
30. Kari Strenfel , Meteorologist
8:52 PM GMT on September 18, 2014
Quoting 27. alongfield:

I'm having a hard time deleting some bad data on my station (KMASTERL6). From 9/14/2014 1534 ET through 9/15/2014 0609 ET, the station was uploading the same set of stale data, rather than current observations.

I was able to remove some of the bad records, but when I try to remove any more than I have, the site shows it removed, but it's back when I check the history after leaving edit mode. I'm using Opera 24 on Windows.


Please delete individual points, not entire rows or columns at a time. Let me know if you are still not able to delete the bad data.
Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
29. Kari Strenfel , Meteorologist
8:47 PM GMT on September 18, 2014
Quoting 26. Dikken:

hi,

I had to remove some data on september 13th. Although the data dwas succesfully removed, the max/min summary still shows the deleted data.

any way to correct this?

best regards, bart


It looks like this is fixed now. Are you still seeing the bad data in the summary table?

Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
28. Kari Strenfel , Meteorologist
8:45 PM GMT on September 18, 2014
Quoting 25. wutswx:

I frequently run into issues with being unable to delete any data rows. I can not delete individual cells, nor can I delete entire rows. I have issues about this FREQUENTLY. I go through the steps as outlined above, and when I complete them and reload the page, the bad data is still there. I have tried this procedure on the latest versions of Safari, Chrome and Firefox on Mac OS X Mavericks. Any idea why this is happening over and over and over and over and over again?


Deleting entire rows or columns does not yet work. Please delete individual points.

Thank you,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
27. alongfield
8:24 PM GMT on September 15, 2014
I'm having a hard time deleting some bad data on my station (KMASTERL6). From 9/14/2014 1534 ET through 9/15/2014 0609 ET, the station was uploading the same set of stale data, rather than current observations.

I was able to remove some of the bad records, but when I try to remove any more than I have, the site shows it removed, but it's back when I check the history after leaving edit mode. I'm using Opera 24 on Windows.
Member Since: February 26, 2009 Posts: 0 Comments: 0
26. Dikken
4:53 PM GMT on September 14, 2014
hi,

I had to remove some data on september 13th. Although the data dwas succesfully removed, the max/min summary still shows the deleted data.

any way to correct this?

best regards, bart
Member Since: January 30, 2012 Posts: 0 Comments: 0
25. wutswx
6:18 AM GMT on September 10, 2014
I frequently run into issues with being unable to delete any data rows. I can not delete individual cells, nor can I delete entire rows. I have issues about this FREQUENTLY. I go through the steps as outlined above, and when I complete them and reload the page, the bad data is still there. I have tried this procedure on the latest versions of Safari, Chrome and Firefox on Mac OS X Mavericks. Any idea why this is happening over and over and over and over and over again?
Member Since: February 1, 2008 Posts: 0 Comments: 0
24. WunderAlertBot (Admin)
5:41 PM GMT on September 04, 2014
PWSmet has created a new entry.
23. Kari Strenfel , Meteorologist
9:24 PM GMT on September 02, 2014
Quoting 20. CaryGazeebo:

Still having the occasional Issues. Today Included. Can't delete Row, only entire Column.. All Browsers, All OS's, all browesers. Ubuntu, MACOS, RedHat, Microslop, Firefox, Chrome, Internet Exploder...

Please advise.

I just discovered I can delete individual entries, still can't fix my -61 degree dew point, but I can live with that!



Hi there,

I was able to delete all of your bad data that I could find. Please let me know of any other specific dates you need editing.

Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
22. Kari Strenfel , Meteorologist
8:33 PM GMT on September 02, 2014
Quoting 21. KMoore:

Hello all,
While I've had my station for years, I've just now gotten the software to report the data. Is there any way to upload the data from the Davis Data Logger (I use a Mac) so there are no gaps in the data? I shut down my computer at night to run permission fixes, etc and to conserve energy.


Since you shut down your computer at night, I suggest purchasing the WeatherBridge device. It allows you to send data to Weather Underground without a computer. Connects directly to your router. More info here:
http://www.ambientweather.com/amweatherbridge.htm l
http://www.ambientweather.com/wunderbridge.html
http://www.meteobridge.com/wiki/index.php/Main_Pa ge
Feel free to contact the makers of Weather Bridge for any additional questions:
info@meteohub.de

Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
21. KMoore
5:15 AM GMT on September 01, 2014
Hello all,
While I've had my station for years, I've just now gotten the software to report the data. Is there any way to upload the data from the Davis Data Logger (I use a Mac) so there are no gaps in the data? I shut down my computer at night to run permission fixes, etc and to conserve energy.
Member Since: August 28, 2014 Posts: 0 Comments: 0
20. CaryGazeebo
10:27 PM GMT on August 29, 2014
Still having the occasional Issues. Today Included. Can't delete Row, only entire Column.. All Browsers, All OS's, all browesers. Ubuntu, MACOS, RedHat, Microslop, Firefox, Chrome, Internet Exploder...

Please advise.

I just discovered I can delete individual entries, still can't fix my -61 degree dew point, but I can live with that!
Quoting 16. CaryGazeebo:

On occasion, my PWS reports waaaay bad data. I found I can delete columns, not rows. In both cases it asks "are you sure" and appears to be missing when viewed from the table view, but in all graphs, it still skews them horribly.. However, when I select entire columns the data get deleted and the graphs again are normalized.

Any ideas??
Member Since: November 25, 2012 Posts: 0 Comments: 1
19. Kari Strenfel , Meteorologist
8:26 PM GMT on August 28, 2014
Quoting 15. thomasjanus:

I am logged in and yes i do get the prompt window to which i click YES remove data and then i change date and come back and the data is back.

another one is 5/7/14 @ 1037. That whole line needs to be deleted but I cant.

the ones you deleted for me are still ok.

why is there so many issues deleting the data?






OK, I have deleted all the data points at 10:37 on July 5th.

Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
18. Kari Strenfel , Meteorologist
5:36 PM GMT on August 26, 2014
Quoting 12. thrackhead:

i tried to edit the bad data 2x [2 different days] now and it won't keep the changes when i go back to graphs. it used to work before the NEW IMPROVED look and feel.


What browser window are you using? Again, try to delete only 1 point at a time, not entire rows. If you tell me the dates with bad data, I would be happy to go in and delete these for you.

Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
17. thomasjanus
7:50 PM GMT on August 25, 2014
ive actually noticed something similar. if i dont delete the whole row but just part of it then it seems to delete ok but if i delete the entire row then after i come back its still there
Member Since: September 8, 2011 Posts: 0 Comments: 6
16. CaryGazeebo
1:24 PM GMT on August 24, 2014
On occasion, my PWS reports waaaay bad data. I found I can delete columns, not rows. In both cases it asks "are you sure" and appears to be missing when viewed from the table view, but in all graphs, it still skews them horribly.. However, when I select entire columns the data get deleted and the graphs again are normalized.

Any ideas??
Member Since: November 25, 2012 Posts: 0 Comments: 1
15. thomasjanus
12:32 PM GMT on August 24, 2014
I am logged in and yes i do get the prompt window to which i click YES remove data and then i change date and come back and the data is back.

another one is 5/7/14 @ 1037. That whole line needs to be deleted but I cant.

the ones you deleted for me are still ok.

why is there so many issues deleting the data?



Quoting 5. PWSmet:



I have removed all the bad data points for you. Please let me know if you still see some bad data in there. Where did you run into problems deleting the data? Did you ever get the prompt window asking if you are sure you would like to delete this data? Where you logged into your Weather Underground account? You can only delete your station data if you are logged in. This way, only the station owners can edit their own data.

Thanks,
Kari
Member Since: September 8, 2011 Posts: 0 Comments: 6
14. RenoSoHill
2:20 AM GMT on August 22, 2014
Like the new blue circle on my station on the map - nice addition.

I do have to laugh about the "Average Temperature" - it's cool for 15 hours and hot for 2 hours but you divide by 2. Kinda' reminds me of what I told my kids when they got a "C" and said it was average! If you stand with one foot on a block of ice and one on a red hot stove - on the AVERAGE - your comfortable......


Member Since: December 12, 2009 Posts: 7 Comments: 11067
13. Kari Strenfel , Meteorologist
4:12 PM GMT on August 19, 2014
Quoting 11. exwickman:

I can't get this feature to work at all. I've tried using it numerous times, the data appears to be deleted but when I return to graph view it is still present. When I then return to the table view it is still in this view as well!
e.g. on my station ISOMERSE59 the data for 7.55 on 18th August has an 80 centigrade temperature reading!
Any thoughts?
Thanks,
Andy


I was able to delete this data for you. Please let me know if you have any other questions.
Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
12. thrackhead
4:08 PM GMT on August 19, 2014
i tried to edit the bad data 2x [2 different days] now and it won't keep the changes when i go back to graphs. it used to work before the NEW IMPROVED look and feel.
Member Since: September 4, 2011 Posts: 0 Comments: 0
11. exwickman
3:26 PM GMT on August 19, 2014
I can't get this feature to work at all. I've tried using it numerous times, the data appears to be deleted but when I return to graph view it is still present. When I then return to the table view it is still in this view as well!
e.g. on my station ISOMERSE59 the data for 7.55 on 18th August has an 80 centigrade temperature reading!
Any thoughts?
Thanks,
Andy
Member Since: September 27, 2012 Posts: 0 Comments: 0
10. Skyepony (Mod)
6:30 PM GMT on August 18, 2014
Quoting 8. PWSmet:



Hi there,

I see the problem. Your station is sending Weather Underground the data as 0.61. Is there a way to reset this value back to zero on your weather station console? Or in you weather station software? We display the data exactly as it comes in.

Thanks,
Kari

I did come to realize this is somehow on my end. The display shows correctly. It must be in the linux box data uploader. It's never handled the pressure right, though that varies by the same factor of wrong & this keeps sending the same wrong data. Thanks! I'll try resetting everything.
Member Since: August 10, 2005 Posts: 191 Comments: 38624
9. Kari Strenfel , Meteorologist
5:21 PM GMT on August 18, 2014
Quoting 7. stationkeeper:

Same problem with my station too. Precip Accum shows -25375 mm. My station name IESPOO1
''

Hi there,

The precip value of -25375 mm translates to -999 inches, which means null data or not available. Your station sends the data to Weather Underground as "-999".

Let me know if you have any questions.
Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
8. Kari Strenfel , Meteorologist
5:16 PM GMT on August 18, 2014
Quoting 6. Skyepony:

Deleted a little data the other day. That worked well.

On 8/10 I had 0.61" of rain that has carried over each day since. Now no matter if it rains or not it says 0.61" for the day. I had 0.08" register on the PWS base yesterday that didn't effect the 0.61" on WU.


Hi there,

I see the problem. Your station is sending Weather Underground the data as 0.61. Is there a way to reset this value back to zero on your weather station console? Or in you weather station software? We display the data exactly as it comes in.

Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
7. stationkeeper
4:14 PM GMT on August 18, 2014
Same problem with my station too. Precip Accum shows -25375 mm. My station name IESPOO1
Member Since: February 18, 2004 Posts: 0 Comments: 0
6. Skyepony (Mod)
5:00 AM GMT on August 14, 2014
Deleted a little data the other day. That worked well.

On 8/10 I had 0.61" of rain that has carried over each day since. Now no matter if it rains or not it says 0.61" for the day. I had 0.08" register on the PWS base yesterday that didn't effect the 0.61" on WU.
Member Since: August 10, 2005 Posts: 191 Comments: 38624
5. Kari Strenfel , Meteorologist
10:56 PM GMT on August 13, 2014
Quoting 4. thomasjanus:

IVICTORI198
June 1st / 6th / 7th 2014 and May 5th / 9th / 14th
All have errored data (- temps] i have deleted them multiple times but they are constantly there!
How do I fix that?


I have removed all the bad data points for you. Please let me know if you still see some bad data in there. Where did you run into problems deleting the data? Did you ever get the prompt window asking if you are sure you would like to delete this data? Where you logged into your Weather Underground account? You can only delete your station data if you are logged in. This way, only the station owners can edit their own data.

Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
4. thomasjanus
3:10 PM GMT on August 13, 2014
IVICTORI198
June 1st / 6th / 7th 2014 and May 5th / 9th / 14th
All have errored data (- temps] i have deleted them multiple times but they are constantly there!
How do I fix that?
Member Since: September 8, 2011 Posts: 0 Comments: 6
3. Kari Strenfel , Meteorologist
8:28 PM GMT on August 12, 2014

Quoting 2. Shedless:

Dear Kari. Thanks for the advice above. I've just joined the PWS and am having an issue with my rain data. I suspect there is some bad data somewhere in my uploaded stats, as my station reading (IENGLAND177) shows Precip Accum: -25375 mm. When I look check my table of data I can't find any entries other than zero or just null.

Any pointers to how I might investigate and fix this please!?

Best regards.
Martin.
Link


Hi Martin,

I found your station: IENGLAND711, and I am not able to see the bad precip accumulation data. What date did you see the bad data on? Is it on the daily view or the weekly and monthly views too?

Thanks,
Kari
Member Since: January 30, 2014 Posts: 13 Comments: 88
2. Shedless
9:37 AM GMT on August 10, 2014
Dear Kari. Thanks for the advice above. I've just joined the PWS and am having an issue with my rain data. I suspect there is some bad data somewhere in my uploaded stats, as my station reading (IENGLAND177) shows Precip Accum: -25375 mm. When I look check my table of data I can't find any entries other than zero or just null.

Any pointers to how I might investigate and fix this please!?

Best regards.
Martin.
Link
Member Since: August 4, 2014 Posts: 0 Comments: 0
1. willowreed
2:25 AM GMT on August 09, 2014
I really do not like this site anymore. I used to come here all the time for my weather and it is no longer user friendly. it takes forever to load, there is crap all over the place. i like what we had before. this thing is a monster and i won't be using it anymore. i never liked weather.com and this is the same thing. Both are annoying and terrible. Bring back the old wunderground.com.
Member Since: January 24, 2011 Posts: 0 Comments: 0

Viewing: 41 - 1

Page: 1 — Blog Index

Top of Page

About PWSmet

Kari is the PWSmet. As a meteorologist at wunderground.com, she has experience setting up and installing many types of personal weather stations.